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Before You Begin
Important

The warranty is void if it is not installed in accordance with the installation
requirements specified in this guide. Read and thoroughly understand the
installation requirements before attempting the installation. If you have any
questions, contact your Kurz customer service representative before attempting
installation.

Using this Manual
Kurz documentation includes printed manuals and product literature, Adobe Acrobat PDF files,
and application online Help files. The Kurz Instruments CD contains all the available
documentation files. To read PDF files, download the free Adobe Acrobat Reader from
www.adobe.com.
The Kurz Instruments website provides additional information:
• World Wide Web: www.kurzinstruments.com
•

Email: service@kurzinstruments.com

•

Documentation links to the most current manuals and literature

You can access device support in the following ways:
• Main: 831-646-5911
•

Phone: 800-424-7356

•

Fax: 831-646-8901

Manual Conventions
The following table lists conventions used in the Kurz documentation, and gives an example of
how each convention is applied.
Table 1.

Conventions used in this manual
Convention

Text type, click, or select (for example,
field names, menus, and commands)
are shown in bold.

For Example
Check the Configuration File checkbox.

Text appearing in a display or window is PRESS ENTER TO
SET METER DATA
shown in courier.
An arrow (→) is used to separate a
menu name from its menu command.

Select Start→All Programs→Kurz Instruments→KzComm.

Simplified directory structures and path Programs Files\Kurz Instruments\KzComm.
names are used in examples. Your
folder names may be different.
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Introduction

Overview
KzComm for Windows communicates with Kurz flow meters to transfer the configuration data
between the Kurz flow meter and the computer. It is backwards compatible with previous
versions of the Series FT and B-Series flow meters, Series 2440 Portable Flow Meters, and the
Series 155 Mass Flow Computer.
KzComm provides the following features for B-Series devices:
• Uploading and downloading the configuration file.
•

Printing the configuration file.

•

Extracting internal log files that provide min/max, event, and trend data.

•

Sensor data loading for the flow calibration and temperature compensation parameters.

•

Basic meter configuration changes both online and offline.

This chapter provides KzComm hardware and software requirements and limitations.
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Hardware Requirements
KzComm uses XMODEM, Modbus RTU, MODBUS TCP/IP, or terminal communications protocols to
communicate with the Kurz Series FT, B-Series, Series 155, and Series 2440.
• The B-Series use the XMODEM communication protocol via USB port, or the MODBUS
protocol via RS-485 port or MODBUS TCP/IP. The Kurz USB device driver or FTDI USB device
driver must be installed before attempting to connect a computer with a B-Series device
via a USB cable.
•

Series 155 Computer/Transmitter uses terminal communications via an RS-232C port.

•

FT Series and Series 2440 Portable Flow Meter use the XMODEM communications protocol
via an RS-232C port.

B-Series Devices
The B-Series devices require:
• A two-wire shielded cable for Modbus RTU.
•

For the XMODEM protocol, a USB Type A-to-mini B cable.
Note

•

The Kurz USB device driver or FTDI USB device driver must be installed
before attempting to connect a computer with a B-Series device via a
USB cable.

For the Modbus TCP/IP protocol, an Ethernet cable to a Modbus TCP/IP to RS-485 gateway.

Series FT Devices
Series FT devices require:
• A one-to-one pin configuration of the communication cable using a DB9 connector at both
ends. The cable (part #260102) is available from Kurz Instruments.
•

One RS-232C communication port on the computer or a USB-to-RS-232C adapter for the
computer.

Series 2440 Models
Series 2440 models require:
• A one-to-one pin configuration of the communication cable using a DB9 connector at both
ends. The cable (part #260102) is available from Kurz Instruments.

1–2

•

One RS-232C communication port on the computer or a USB-to-RS-232C adapter for the
computer.

•

An available I/O adapter board. The I/O adapter board (part #260106 and #420334) for the
Series 2440 is available from Kurz Instruments.
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Series 155 Mass Flow Computer
KzComm can communicate with a Series 155 Mass Flow Computer running KAS 6.81. Series 155
configuration files can be uploaded, downloaded, and printed for reporting purposes. Functions
that are not configured are not downloaded and do not appear in the report. KzComm does not
support pass-through commands for reconfiguring devices connected to the Series 155.
Series 155 models require one RS-232C communication port on the computer or a USB-toRS-232C adapter for the computer.
Table 1-1.

Kurz 155-Compatible Product Lines
Kurz B-Series Product Line

Kurz 410FTB

Kurz 454PFTB

Kurz 534FTB

Kurz 454FTB

Kurz 504FTB

Kurz 534FTB-CL2

Kurz 454FTB-WGF

Kurz 524FTB-UHP

Kurz K-BAR 2000B

Kurz FT-Series and Legacy Product Lines
Kurz 220

Kurz 504FT

Kurz 542

Kurz 410

Kurz 500

Kurz 550E

Kurz 410FT

Kurz 510

Kurz 730

Kurz 420

Kurz 510FT

Kurz K-BAR 16

Kurz 452

Kurz 522-UHP

Kurz K-BAR 24

Kurz 454FT

Kurz 524FT-UHP

Kurz K-BAR 2000

Kurz 502

Software Requirements
KzComm is supported on Windows XP, Windows Vista, Windows 7, and Windows 8. All platforms
require up-to-date service packs.
Note

On Windows Vista, downloading the Trend Log has infrequently caused
the operating system to freeze (no screen activity). Restart the computer
as described in your computer hardware manual.

Basic computer knowledge is necessary for copying and moving files, navigating file structures
and identifying file types, and installing applications. You will need a decompression utility to
extract files from compressed file packages.
The Kurz USB device driver or FTDI USB device driver must be installed before attempting to
connect a computer with a B-Series device via a USB cable. Both drivers are available during the
KzComm installation, on the Kurz customer CD in the USB Device Driver folder, and on the Kurz
website (kurzinstruments.com). The FTDI USB driver is a 64-bit compatible virtual COM port (VCP)
driver available from the FTDI Chip website (ftdichip.com).
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Chapter 2

Installing KzComm

Overview
This chapter provides step-by-step instructions for installing KzComm and Tera Term. It also
provides information for configuring and identifying the communication port so that KzComm
can communication with Kurz devices.
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Installing KzComm
Download the current KzComm version from the Kurz website:
1> Click Technical Information.
2>

Click Software Downloads.

3>

Under the KzComm heading, click KzComm Zip Download
(the version number is included in the link name).

4>

Save the file to your computer.

5>

After the download is complete, open the KzComm zip file
(the version number is included in the filename) and extract the contents.

6>

Start the installation by double-clicking the setup.exe file.

7>

If you receive a security warning, click Run.

8>

The installation wizard starts with the welcome message. Click Next.
The End User License Agreement dialog box appears.

9>

Check to accept the agreement and click Next.
The Destination Folder dialog box appears.

10>

You should accept the default (Program Files\Kurz Instruments\KzComm) unless
you are familiar with the Windows folder structure. The Program Files folder appears
as Program Files(x86) on Windows 64-bit systems. Click Next.
The Supplemental Program dialog box appears.

11>

If you are going to communicate with a flow meter using a USB cable, you must include the
Kurz or FTDI USB driver. Install the Tera Term terminal emulator if your environment allows
you to work remotely. Click Next.
See “USB Drivers” on page 2-4 for USB requirements.

12>

The Ready To Install dialog box appears. Click Install.
A installation progress meter appears.

13>

The Completed dialog box appears. Click Finish.
If you selected to install the Kurz USB driver, the FTDI USB driver, or Tera Term,
the installer for that component appears. All installers appear on the next page.

A KzComm icon and KzComm Data icon appear on the desktop. All KzComm data is automatically
stored in the Windows default applications data folder.
• Windows XP default:
C:\Documents and Settings\All Users\Application Data\Kurz Instruments\KzComm
•

2–2

Windows Vista and Windows 7 & 8 default:
C:\Program Data\Kurz Instruments\KzComm
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Installing the Kurz USB Driver
If you selected to install the Kurz USB driver, the installer automatically starts:
1> If prompted by the User Account Control to run the setup program, click Yes to allow the
program to make changes.
2>

If prompted to verify the installation, click Install to allow the program to make changes.

3>

The Kurz USB driver is not Windows logo tested. If prompted, click Continue Anyway.

Installing the FTDI USB Driver
If you selected to install the FTDI USB driver, the installer automatically starts:
1> The FTDIChip CDM Drivers extraction wizard appears. Click Extract.
2>

The installation wizard starts with the welcome message. Click Next.
An installation meter appears.

3>

The Completed dialog box appears. Click Finish.

Installing Tera Term
If you selected to install Tera Term, the installer automatically starts:
1> The installation wizard starts with the welcome message. Click Next.
The End User License Agreement dialog box appears.
2>

Check to accept the agreement and click Next.
The Destination Folder dialog box appears.

3>

You should accept the default (Program Files\TeraTerm) unless you are familiar
with the Windows folder structure. Click Next.
The Select Components dialog box appears. The installation options Standard, Full,
Compact, and Custom.

4>

Select Compact installation from the installation type drop-down list. Click Next.

5>

The Select Language dialog box appears

6>

Choose the appropriate language. Click Next.
The Start Menu dialog box appears.

7>

Accept the default shortcut for the Start menu. Click Next.
The Additional Tasks dialog box appears.

8>

Accept the default tasks. Click Next.

9>

The Ready To Install dialog box appears. Click Install.
An installation progress meter appears.

10>

The Completed dialog box appears. Click Finish.
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USB Drivers
The Kurz USB device driver or FTDI USB device driver must be installed before attempting to
connect a computer with a B-Series device via a USB cable. Both drivers are available during the
KzComm installation, on the Kurz customer CD in the USB Device Driver folder, and on the Kurz
website (kurzinstruments.com). The FTDI USB driver is a 64-bit compatible virtual com port (VCP)
driver available from the FTDI Chip website (ftdichip.com).
Refer to Appendix B, “USB Driver Installation,” for identifying and installing the correct USB driver.

Configuring KzComm
Start KzComm by double-clicking its desktop icon or selecting Start→All Programs→Kurz
Instruments→KzComm. The KzComm main window opens.

Figure 2-1.

KzComm main window

Note

The Kurz USB device driver or FTDI USB device driver must be installed
before attempting to connect a computer with a B-Series device via a
USB cable.

The Help menu options are as follows:
• Help Topics provides information about the application features and functions.
•

2–4

About KzComm provides the application version.
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Configuring the Communications Port
You must configure the communications parameters before the KzComm window can show the
sensor serial number and the tag name for the connected device.
Note

KzComm retains the settings from the last communications configuration
and assumes the connection has not changed. If you use KzComm to
communicate with multiple devices, Kurz recommends that you
configure or verify the Communications Setup each time to ensure you
are connecting to the correct device.

To configure the KzComm communications port:
1> Select Communications→Configure.
The Communication Setup dialog box appears.

Figure 2-2.

Communications Setup dialog box

2>

Click the radio button next to the required communications protocol and set the
parameters as described on page 2-6.

3>

Click OK.
KzComm retrieves and displays the serial number and tag name for B-Series devices
with firmware 1.05 or newer. The serial number and tag name do not appear for other
Kurz devices.
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XMODEM via USB or DB9 RS-232C
For XMODEM via a USB or DB9 RS-232 cable connection, COM port numbers and available COM
port options are based on hardware and software configuration.
• A communications port option appears only when there is a physical port or a hardware
device is attached to the computer and a device driver identifies it as a COM port.
•

The Kurz USB-HID -> COM device option appears only if you installed the Kurz USB driver
and the computer is connected to a B-Series device with a barcode ID starting with an
A or B, or is less than C51937.

See “Identifying the COM Port” on page 2-7 for additional information.
Note
If a USB-to-RS-232 or USB-to-RS-485 adapter is used then it will appear
as a COM port.
The baud rate options are:
4800
19200
9600
38400
14400
57600
Note
B-Series devices support only 9600 baud for the XMODEM protocol.

Modbus Serial RTU via RS-485
For Modbus Serial RTU, the COM port numbers and available COM port options are based on
hardware and software configuration. You must use a USB-to-RS-485 converter to communicate
via Modbus. A communications port option appears only when there is a physical port or a
hardware device is attached to the computer and a device driver identifies it as a COM port. Refer
to your converter documentation for COM port identification information. See “Identifying the
COM Port” on page 2-7 for additional information.
The baud rate options are:
9600
14400
19200

38400
57600

The Modbus address default is 1 (except for the Kurz K-BAR multipoint system).
Note

The B-Series Modbus setup for ASCII transmission framing is not
supported by KzComm. If KzComm is to be used over Modbus,
RTU transmission framing must be used.

Modbus TCP/IP via Ethernet or Wireless
For Modbus TCP/IP, enter the IP address of the Modbus TCP/IP device and the Modbus address of
the device with which to communicate.

2–6
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Series 155 via DB9 RS-232C
For Series 155 communications, the COM port numbers and available COM port options are
based on hardware and software configuration. A communications port option appears only
when there is a physical port or a hardware device is attached to the computer and a device
driver identifies it as a COM port. See “Identifying the COM Port” for additional information.
The baud rate options are:
1200
9600
Note
KzComm can only communicate with Series 155 models using KAS 6.81
firmware. Older KAS firmware versions are not supported.

Identifying the COM Port
If the drop-down list for the COM Port field does not provide an identifiable name, open
Windows Device Manager. You can do this by using one of the following methods:
• Select Control Panel→Device Manager.
•

Open the Windows Computer Management window and click Device Manager.

•

For Windows XP, choose Start→Run, type devmgmt.msc in the Open field of the Run
dialog box, and press Enter.

•

For Windows 7 and Windows 8, choose Start and type Device Manager in the search field.
You can select it when it appears as an option.

In the Device Manager window:
1> Expand Ports (COM & LPT).
If you installed the Kurz USB driver and a B-Series device with a barcode lower than
C51938 is currently connected, it will be labeled as Kurz USB-HID -> COM device.
If you installed the FTDI USB driver and a B-Series device with a barcode C51938 or
higher is currently connected, it will be labeled as USB Serial Port (COM#).
If a USB-to-RS-485 adapter is used, its name may reference the manufacturer.
2>

To verify the port number, unplug the USB connector, and then plug it back in.
The COM port entry that disappears and reappears is the port used for the Kurz device.
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Configuring Tera Term
If you are using the Tera Term terminal emulator, the flow meter must be turned on and
connected to the computer.
1> Double-click the Tera Term icon.
The New Connection dialog box appears.
2>

Select the Serial radio button.

3>

In the Port drop-down field, select the COM port associated with either the Kurz USB driver
or the FTDI driver.
Tera Term automatically configures the COM port based on the Windows Device
Manager setting for the COM port. If garbage characters appear in Tera Term window,
the communication parameters must be corrected.

4>

Select Setup→Serial Port.
The Serial Port Setup dialog box appears.

Figure 2-3.
5>

6>

Tera Term serial port setup

Set the parameters as follows and then click OK:
—

Baud rate – 9600

—

Data bits – 8

—

Parity – none

—

Stop bits – 1

—

Flow control – none

If garbage characters continue to appear, select Control→Reset Port.

When synchronized communication is established, the Tera Term window will echo all the
information appearing on the B-Series display.
Note

2–8

Terminal echo must be ON for using the computer keyboard to emulate
the B-Series keypad. Terminal echo should be OFF if you are accessing
the log files.
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Table 2-1 describes the keyboard keys that are equivalent to the flow meter keypad.
Table 2-1.

Keyboard-Keypad Equivalent Keys

Computer Keyboard

Flow Meter Keypad

Function

p

P

A lowercase P invokes Program mode. An access code
is required. During data entry it allows you to skip over
a field without entering anything.

d

D

A lowercase D invokes DIsplay mode. No access code is
required.

l

L

A lowercase L invokes Log mode. No access code is
required.

<Enter>

E

Pressing <Enter> invokes Extended Utilities mode. An
access code is required. During data entry it accepts
the data.

c

C

During data entry, a lowercase C clears the value. It
also acknowledges an active system fault.

h

H

A lowercase H returns to Run mode or backs out of a
menu.

+

The plus key (+) toggles terminal echo On or Off.

^

^/ Yes

Pressing Shift-6 scrolls forward in a selection list.

v

v / No

A lowercase V scrolls backward in a selection list.

–

–

A hyphen or minus key is used for numeric and text
data.

.



A period or decimal is used in floating point and text
data.

0-9

0-9
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Number keys are used for numeric data and access
codes.
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Using KzComm

Overview
This chapter provides information on KzComm settings options for uploading, downloading,
viewing, and printing flow meter configuration files. It also provides information about the
Min/Max Log file, the Event Log file, and the Trend Log file.
Note

All examples use a simplified directory structure, such as Program
Data\Kurz Instruments\KzComm. However, your directory structure
will include a drive letter (such as C) and possibly other folder names,
such as Program Files (x86) or custom locations.
The examples in this guide use a custom configuration. Output, fields,
and buttons for your configuration will appear differently.
Buttons are greyed when connections are not established, devices are
not properly configured, or all required field data has not been
entered. The examples used in this guide show all buttons and fields
active to improve readability and printing.

For B-Series devices, there are instructions for online and offline configuration setup.
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Starting KzComm
After setting the communications parameters, as specified “Configuring the Communications
Port,” KzComm shows the tag name and sensor serial number for the attached Kurz device in the
main window, as shown in the Figure 3-1.
Note

Figure 3-1.

KzComm retrieves and displays the serial number and tag name for
B-Series devices with firmware 1.05 or newer. The serial number and tag
name do not appear for other Kurz devices.

KzComm Window after configuration

KzComm retains the settings from the last communications configuration and assumes the
connection has not changed. If you use KzComm to communicate with multiple devices, Kurz
recommends that you configure or verify the Communications Setup each time to ensure you are
connecting to the correct device.
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Downloading Files
Download (Target to PC) allows you to download the files from Kurz devices. Select
File→Download (Target to PC) to open the Download (Target to PC) dialog box.

Figure 3-2.

Download (Target to PC) dialog box

Note

Download options are based on the device, device firmware, and the
communications method you selected. The Min/Max, Event, and Trend
log files are not supported with Series FT, Series 155, and Series 2440
devices or with B-Series devices using firmware 1.04 and earlier.
The Min/Max Log, Event Log, and Trend Log files cannot be downloaded
until the device has completed boot-up mode.

Downloading a file automatically opens the file with the default application for that file type.
All log files are in a comma-separated value (.csv) format and the configuration file is in a readable
text (.txt) format.

Downloading a Configuration File
Downloading a device configuration file allows you to:
• Maintain a backup configuration file of the unit setup for maintenance purposes.
•

Convert the configuration file to a readable text file so that you can review the device
setup.

To download a configuration file:
1> Check the Configuration file checkbox in the Download (Target to PC) dialog box and
click OK.
2>

A navigation window opens where you specify the filename and file type. A default
filename appears (that can include the sensor serial number if preconfigured). You should
accept the default file location (Program Data\Kurz Instruments\KzComm) and default
configuration file (.cf) type. Click Save.

A viewable text version of the configuration file automatically opens.
Note
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If an error occurs, click OK in the message box and retry downloading the
configuration file.
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Downloading Min/Max Log and Event Log Files
The Min/Max Log file is used to determine the range of the flow rate, temperature, and
electronics temperature for the process being measured by the B-Series device. The output file
contains 20 records (up to one entry per day per category) for each of the following events:
• Minimum and maximum flow rate
•

Minimum and maximum process temperature

•

Minimum and maximum electronics temperature

The Event Log file contains up to 160 of the most recent events determined and reported by the
B-Series device.
To download the Min/Max Log and Event Log files:
1> Check the Min/Max and Event Log files checkbox in the Download (Target to PC) dialog
box and click OK.
2>

A navigation window opens where you specify the filename and file type. A default
filename appears (that can include the sensor serial number if preconfigured) appended
with minmax, followed by another filename appended with event. You should accept the
default file location (ProgramData\Kurz Instruments\KzComm) and default file type (.csv).
Click Save.
Note

If an error occurs, click OK and verify the device is not in Boot-Up mode.
Windows uses WordPad as the default application for opening CSV files
unless a spreadsheet application is installed.

A viewable version of the Min/Max Log and Event Log files automatically opens.
Note

If an error occurs, click OK and verify the device is not in boot-up mode.

Downloading the Trend Log File
Important

The log data is in volatile memory. A power cycle will clear the Trend Log file.

The Trend Log file contains 20,416 records. Each record contains the runtime, flow rate, and
process temperature data taken every 10 seconds for approximately 2.3 days. When the Trend
Log file is full, the oldest data is replaced with the newest data. The data shows how the process
being measured by the Kurz device changes with time. The Trend Log file will contain details if an
unusual event occurs with the process. Downloading the Trend Log file takes approximately
4 minutes using Modbus RTU at 38400 baud and approximately 17 minutes using the Xmodem
protocol.
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To download the Trend Log file:
1> Check the Trend Log file checkbox in the Download (Target to PC) dialog box and click OK.
2>

A navigation window opens where you specify the filename and file type. A default
filename appears (that can include the sensor serial number if preconfigured) appended
with trend. You should accept the default file location (ProgramData\Kurz
Instruments\KzComm) and default file type (.csv). Click Save.
Note

If an error occurs, click OK and verify the device is not in boot-up mode.
Windows uses WordPad as the default application for opening CSV files
unless a spreadsheet application is installed.

A graph of the Trend Log file appears, as shown in the following example.

Figure 3-3.
3>

Trend Log file example

You can save the graph as a JGP image by clicking Save Image. The default filename
appends “trend” to the filename.

Uploading a Configuration File
To upload a configuration file:
1> Select File→Upload (PC to Target).
2>

A navigation window opens where you select the file containing the configuration
information. The default file location is ProgramData\Kurz Instruments\KzComm.
Click Open.

3>

If an error occurs, click OK and repeat the steps for uploading a configuration file.
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Creating a Readable Configuration File
Configuration files are in a binary format. Configuration files must be converted to a text format
before they can be printed or read.
To create a readable configuration file:
1> Select File→Create Printable File.
2>

A navigation window opens where you select the configuration file you want to read or
print. The default file location is ProgramData\Kurz Instruments\KzComm. Click Open.

3>

Another navigation window opens where you specify the output filename and file type. A
default filename and default file type (.txt) appears with the default file location
(ProgramData\Kurz Instruments\KzComm). You should accept the default file location and
default file type. Click Save.

Viewing a Configuration File
Note

The View option is disabled until you create a printable file.

Use a text editor (such as Notepad) to view the text version of the configuration file.
To view the configuration file:
1> Select File→View.
The default text editor opens and automatically shows the configuration file created
with Create Printable File.
If you want to open another converted configuration file in the text editor, select
File→Open and navigate to the location where the other converted configuration file
resides.
2>

Close the text editor when finished.

Printing a Configuration File
Note

The Print option is disabled until you create a printable file.

To print the configuration file:
1> Select File→Print.
The file is sent to the default printer.
2>
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If you want to use another printer, open the file in a text editor as described in “Viewing a
Configuration File” and select File→Print from the text editor menu.
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Updating the Flow Calibration Data
Important

Updating flow calibration data should only occur with approval
from Kurz Technical Support.

The flow calibration data can be updated for a B-Series device using a valid flow calibration data
file. With a valid data file, you can update current calibration data, change the calibration data for
different gases, or update Velocity Temperature Mapping (VTM) data.
Note

This feature is not available for the Series 155.

To update the flow calibration data:
1> Select Update→Flow Calibration Data.
2>

A navigation window opens where you select the flow calibration data file you want to use.
The default file location is ProgramData\Kurz Instruments\KzComm. Click Open.

3>

If an error occurs, click OK and repeat the steps for updating the flow calibration data.

Updating the Sensor Data
Important

Updating sensor data should only occur with approval
from Kurz Technical Support.

The sensor data can be updated for a B-Series device using a valid sensor data file. With a valid
data file, you can update sensor-specific resistance temperature device (RTD) calibration
coefficients.
Note

This feature is not available for the Series FT, Series 155, or Series 2440.

To update the temperature compensation data:
1> Select Update→Sensor Data.
2>

A navigation window opens where you select the sensor data file you want to use.
The default file location is ProgramData\Kurz Instruments\KzComm. Click Open.

3>

If an error occurs, click OK and repeat the steps for updating the temperature
compensation data.
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B-Series Device Setup
The B-Series setup in the Wizard menu is used to configure only a B-Series device with
2.00 or newer firmware.
Note

An error message appears if you attempt to use the setup with any other
devices.
The examples in this guide use a custom configuration for improved
readability and printing. Output, fields, and buttons for your
configuration will appear differently. Unavailable options are greyed until
connection or configuration requirements are established.

1>

Select Wizard→B-Series Setup.
The Connection Type dialog box appears.

Figure 3-4.
2>
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Connection Type dialog box

Choose Online if you are currently connected to the B-Series device or Offline if you will be
using a configuration file on your computer.
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Online B-Series Device Setup
Choose Online if you are currently connected to the B-Series device.
1> Select Online and click Next.
The Communications Setup dialog box appears and prompts you for the
connection type.

Figure 3-5.
2>

Communications Setup dialog box

Select the connection type and click OK.

A series of Upload/Download status messages appear followed by the B-Series Information
dialog box.
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Figure 3-6.

Connection Type dialog box

The process continues similar to the offline setup. Continue to page 3-12 for the “Initial Setup for
First Time Use” and page 3-19 for “Flow Area Configuration.”
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Offline B-Series Device Setup
Choose Offline if you are not connected to the B-Series device.
1> Select Offline and click Next.
2>

A navigation window opens where you select the configuration file you want to use. The
default file location is ProgramData\Kurz Instruments\KzComm. Click Open.

The B-Series Information dialog box appears.

Figure 3-7.

B-Series Information dialog box

The sensor serial number, tag name, modbus address, and gas for the device appear for
verification purposes.
Choose the mode of configuration:
• Initial Setup for First Time Use
Used the first time you are setting up the device. Defaults are used for initial numbers,
but these can be overwritten.
•

Reconfiguration
Used to make device changes after initial configuration and for more advanced users.
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Initial Setup for First Time Use
After you have chosen the configuration mode, click Next.
You have the option for measuring point velocity, volumetric flow rate, or mass rate. Appendix A
provides field values for point velocity, volumetric flow rate, and mass rate.

Figure 3-8.
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Measurement Mode dialog box
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Measuring Point Velocity
Point velocity is measured in the following units:
• Standard Feet per Minute (SFPM)
•

Normal Meters per Second (NMPS)

•

Standard Meters per Second (SMPS)

The availability and appearance of additional options are based on the flow units. Additional
fields appear if you customize temperature or pressure. Custom values revert to standard values
if the number is approximately a standard value.
The Area and Probe Insertion Depth fields appear only with insertion meters. Refer to “Flow Area
Configuration” on page 3-19 and “Probe Insertion Configuration” on page 3-20 for information on
these fields.
“Measuring Point Velocity” on page A-2 provides field values for point velocity.
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The second set of analog outputs (AO2) do not appear with the HART option. “Analog Outputs”
on page A-5 provides field values for analog outputs.

The Modbus address defines a specific device using a value from 1 to 247. For the B-Series, use
option 19 from the Display menu to find the Modbus address assigned to a device. The baud rate
determines the rate of data transmission to each specified device. Slower baud rates are
frequently used for longer distances and noisier communication lines.
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Measuring Volumetric Flow Rate
Volumetric rate is measured in the following units:
• Standard Cubic Feet per Minute (SCFM)
•

Standard Cubic Feet per Hour (SCFH)

•

Normal Liters per Minute (NLPM)

•

Normal Cubic Meters per Hour (NCMH)

•

Standard Liters per Minute (SLPM)

•

Standard Cubic Meters per Hour (SCMH)

The availability and appearance of additional options are based on the flow units. Additional
fields appear if you customize temperature or pressure. Custom values revert to standard values
if the number is approximately a standard value.
The Area and Probe Insertion Depth fields appear only with insertion meters. Refer to “Flow Area
Configuration” on page 3-19 and “Probe Insertion Configuration” on page 3-20 for information on
these fields.
“Measuring Volumetric Flow Rate” on page A-3 provides field values for volumetric flow rate.
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The second set of analog outputs (AO2) do not appear with the HART option. “Analog Outputs”
on page A-5 provides field values for analog outputs.

The Modbus address defines a specific device using a value from 1 to 247. For the B-Series, use
option 19 from the Display menu to find the Modbus address assigned to a device. The baud rate
determines the rate of data transmission to each specified device. Slower baud rates are
frequently used for longer distances and noisier communication lines.
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Measuring Mass Rate
Mass rate is measured in the following units:
• Pounds per Minute (PPM)
•

Pounds per Hour (PPH)

•

Kilograms per Minute (KPM)

•

Kilograms per Hour (KPH)

The availability and appearance of additional options are based on the flow units. Additional
fields appear if you customize temperature or pressure. Custom values revert to standard values
if the number is approximately a standard value.
The Area and Probe Insertion Depth fields appear only with insertion meters. Refer to “Flow Area
Configuration” on page 3-19 and “Probe Insertion Configuration” on page 3-20 for information on
these fields.
“Measuring Mass Rate” on page A-4 provides field values for mass rate.
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The second set of analog outputs (AO2) do not appear with the HART option. “Analog Outputs”
on page A-5 provides field values for analog outputs.

The Modbus address defines a specific device using a value from 1 to 247. For the B-Series, use
option 19 from the Display menu to find the Modbus address assigned to a device. The baud rate
determines the rate of data transmission to each specified device. Slower baud rates are
frequently used for longer distances and noisier communication lines.“Modbus Address” on
page A-5 provides field values for Modbus options.
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Flow Area Configuration
The Area field and Area Wizard button appear only with insertion meters.

Figure 3-9.

Flow Meter Commissioning dialog box

The Area Wizard button simplifies the entry of the Area by allowing you to specify the circular
dimensions (custom pipe), rectangular dimensions (duct), or nominal pipe size (NPS) dimensions.
The measurement units are based on the specified flow units (either inches or millimeters).

Figure 3-10. Area Wizard dialog box
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The NPS options are as follows:
NPS: 1.5, DN: 40, SCH 40
NPS: 1.5, DN: 40, SCH 80
NPS: 2.0, DN: 50, SCH 40
NPS: 2.0, DN: 50, SCH 80
NPS: 2.5, DN: 65, SCH 40
NPS: 2.5, DN: 65, SCH 80
NPS: 3.0, DN: 80, SCH 40
NPS: 3.0, DN: 80, SCH 80
NPS: 3.5, DN: 90, SCH 40
NPS: 3.5, DN: 90, SCH 80
NPS: 4.0, DN: 100, SCH 40
NPS: 4.0, DN: 100, SCH 80
NPS: 4.5, DN: 115, SCH 40
NPS: 4.5, DN: 115, SCH 80

NPS: 5.0, DN: 125, SCH 40
NPS: 5.0, DN: 125, SCH 80
NPS: 6.0, DN: 150, SCH 40
NPS: 6.0, DN: 150, SCH 80
NPS: 8.0, DN: 200, SCH 20
NPS: 8.0, DN: 200, SCH 40
NPS: 8.0, DN: 200, SCH 80
NPS: 10.0, DN: 250, SCH 20
NPS: 10.0, DN: 250, SCH 40
NPS: 10.0, DN: 250, SCH 80
NPS: 12.0, DN: 300, SCH 20
NPS: 12.0, DN: 300, SCH 40
NPS: 12.0, DN: 300, SCH 80
NPS: 14.0, DN: 350, SCH 20

NPS: 14.0, DN: 350, SCH 40
NPS: 14.0, DN: 350, SCH 80
NPS: 16.0, DN: 400, SCH 20
NPS: 16.0, DN: 400, SCH 40
NPS: 16.0, DN: 400, SCH 80
NPS: 18.0, DN: 450, SCH 20
NPS: 18.0, DN: 450, SCH 40
NPS: 18.0, DN: 450, SCH 80
NPS: 20.0, DN: 500, SCH 20
NPS: 20.0, DN: 500, SCH 40
NPS: 20.0, DN: 500, SCH 80
NPS: 24.0, DN: 600, SCH 20
NPS: 24.0, DN: 600, SCH 40
NPS: 24.0, DN: 600, SCH 80

Probe Insertion Configuration
The Probe Insertion Depth field and Insertion Diagram button appear only for insertion meters.
The Insertion Depth diagram shows how to measure the probe insertion depth.

Figure 3-11. Insertion Depth diagram
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Summary
The Summary dialog box provides all the measurement parameters with all changes highlighted
in yellow. By hovering the cursor over a changed field, a pop-up shows the original value.

Figure 3-12. Summary dialog box with changes

The Finish button is disabled if no changes have been made.
If you chose to acquire the configuration data in Online mode, you are prompted to save the
configuration file and upload the changed configuration to the attached B-Series device.

Figure 3-13. Online Options dialog box

If you select Save Config File, a navigation window opens where you specify the output filename
and file type. A default filename and default file type (.cf) appears with the default file location
(ProgramData\Kurz Instruments\KzComm). You should accept the default file location and default
file type. Click Save.
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Chapter 4

Troubleshooting

Overview
This chapter provides known issues and their resolution. Contact Kurz customer service for
additional assistance. Contact information is available on the back of the cover page of this
guide.
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Communications Cannot Be Established
For any invalid communications setup, the following error message appears:
“Unable to communicate with Kurz Instruments device. Possible reasons include:
Invalid communications setup.”
“Invalid communications setup. Unable to find device.”
KzComm retains the settings from the last communications configuration and assumes the
connection has not changed. If you use KzComm to communicate with multiple devices, Kurz
recommends that you configure or verify the Communications Setup each time to ensure you are
connecting to the correct device.

Startup Identification Is Incorrect
KzComm retrieves and displays the serial number and tag name for B-Series devices with
firmware 1.05 or newer. The serial number and tag name do not appear for other Kurz devices.
One of the following messages appears:
“MFT B-Series with 1.04 or older firmware does not support displaying sensor serial
and tag name via XMODEM.”
“MFT\PTA devices do not support displaying sensor serial and tag name.”
“Series 155 does not support displaying sensor serial and tag name.”

Unable to Download Log Files
Download options are based on the device, device firmware, and the communications method
you select. Not all download options may be available for your device.
• When connecting with Xmodem, downloading the Min/Max Log, Event Log,
and Trend Log files requires a B-Series device using firmware 1.05 or newer.
•

When connecting with Modbus, downloading the Min/Max Log and
Event Log files requires a B-Series device using firmware 1.00 or newer.

•

When connecting with Modbus, downloading the Trend Log files requires a
B-Series device using firmware 1.05 or newer.

Operating System Freezes
On Windows Vista, downloading the trend log has infrequently caused the operating
system to freeze (no screen activity). Restart the computer as described in your computer
hardware manual.
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Resetting the Xmodem COM Port
This section describes how to reset the Xmodem COM port when errors occur. You can also refer
to “Using Tera Term Terminal Emulator” to help resolve configuration issues.
This function is used when a terminal emulator application is returning garbage characters, or
when KzComm is unable to communicate with a B-Series device using the XMODEM protocol and
the setup and connections are valid.
Note

This feature is disabled if XMODEM is not the chosen communications
protocol.

It is common to incorrectly exit a terminal emulator, improperly disconnect a flow meter from a
computer, or simply power-down a flow meter while it is actively communicating with a
computer. Resetting the communications port typically corrects the communications problem
between the computer and its COM port.
Important

Always exit/close a terminal emulator before disconnecting or powering down
a flow meter.

KzComm Showing Errors with Valid B-Series Device
Use the Reset Xmodem COM port feature when KzComm returns a warning or indicates that
communications are invalid when you are using a valid setup to a B-Series device.
1> Verify connection between computer and B-Series device using a proper USB cable, ensure
power is supplied to unit, and confirm the COM port is enumerated and the
communications configuration is valid.
2>

Open KzComm and select Communications→Reset Xmodem COM Port to reset the
Xmodem COM port.

3>

Repeat the previous command.

Terminal Emulator Returning Garbage
Use the Reset Xmodem COM port feature when the terminal emulator is returning garbage, and
the emulator does not provide the option to reset the port.
1> Disconnect or close the terminal emulator application.
2>

Open KzComm and select Communications→Reset Xmodem COM Port to reset the
Xmodem COM port.

3>

Open the terminal emulator application, which should now show valid data.

The Tera Term emulator also supports the reset option, as described in“Using Tera Term Terminal
Emulator” on page 4-4.
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Using Tera Term Terminal Emulator
This section describes how to setup the Tera Term terminal emulator when errors occur. You can
also refer to “Resetting the Xmodem COM Port” to help resolve configuration issues.
Note

Always disconnect from the terminal before disconnecting or powering
down the B-Series device.

1>

Install Tera Term v4.65 (or later), and then open the application.
You should allow the installer to create a shortcut on your desktop.

2>

Connect to the COM port identified with the meter.
Tera Term v4.65 (or later) supports connecting to COM1 through COM15.
Tera Term v3.1.3 supports connecting to COM1 through COM4.

3>

If garbage appears, use the Device Manager to change the COM port to a low number.
Follow the steps for opening the Device Manager, as specified in “Identifying the COM
Port” on page 2-7.

4>

From the Tera Term window, choose Control→Reset port.

5>

Save the setup by selecting Setup→Save Setup.

Examples Don’t Match
The examples in this guide use a custom configuration. Output, fields, and buttons for your
configuration will appear differently.
Buttons are greyed when connections are not established, devices are not properly configured, or
all required field data has not been entered. The examples used in this guide show all buttons and
fields active to improve readability and printing.
Most images were captured on the Windows XP and Windows 7 platforms. The appearance of
dialog boxes and windows for these platforms is different.
All examples use a simplified directory structure, such as Program Data\Kurz
Instruments\KzComm. However, your directory structure will include a drive letter (such as C) and
possibly other folder names, such as Program Files (x86) or custom locations.

4–4

KzComm User’s Guide

Troubleshooting

B-Series Boot Mode
The B-Series device performs a boot (power-on) test to verify that configuration, sensor, and
wiring settings are valid. During the boot test, the following information appears on the device
display:
KURZ INSTRUMENTS
DISPLAY DRIVER 4.1

The device display or a terminal emulator will show that sensor testing is in-progress:
CHECKING TYPE OF
CONNECTED SENSOR

If an error message appears after the sensor testing then the unit is stuck in Boot mode due to a
sensor mismatch, wiring, or other problem. At this point the B-Series device will not allow
downloading the Min/Max Log, Event Log, and Trend Log files. To force the device to exit Boot
mode, press the C key on the device keypad or through the terminal emulator and then
disconnect from the terminal emulator.
Once Boot mode is complete the following information appears:
KURZ INSTRUMENTS
SERIES MFT-B

Followed by the final sensor test:
WAIT PERFORMING
SENSOR LEAK TEST

You can start downloading the Min/Max Log, Event Log, and Trend Log files.
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Appendix A

Configuration Fields

Overview
This appendix provides the field values for measuring point velocity, volumetric flow rate, and
mass flow rate.
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Measuring Point Velocity
The following tables describe the flow unit options:
• Standard Feet per Minute (SFPM)
•

Normal Meters per Second (NMPS)

•

Standard Meters per Second (SMPS)

Table A-1 describes the Flow Meter Commissioning point velocity field options.
Table A-1.

Point Velocity Flow Rate Units
Field Name

Customer Ref. Temperature

Volumetric Flow
Rate Units
SFPM

32°F, 68°F, 77°F,
Custom Temperature

NMPS

0°C

SMPS

0°C, 20°C, 25°C,
Custom Temperature

Custom Ref. Temperature

Customer Ref. Pressure

A–2

Field Value

A value from -250 to 250
SFPM

14.696 PSIA,
Custom Pressure

NMPS

101.325 kPa

SMPS

101.325 kPa,
Custom Pressure

Custom Pressure

A value from 10 to 1,000

Meter Filter Time Constant (sec)

A value from 0 to 600
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Measuring Volumetric Flow Rate
The following tables describe the flow unit options:
• Standard Cubic Feet per Minute (SCFM)
•

Standard Cubic Feet per Hour (SCFH)

•

Normal Liters per Minute (NLPM)

•

Normal Cubic Meters per Hour (NCMH)

•

Standard Liters per Minute (SLPM)

•

Standard Cubic Meters per Hour (SCMH)

Table A-2 describes the volumetric flow rate field options.
Table A-2.

Volumetric Flow Rate Units
Field Name

Customer Ref. Temperature

Volumetric Flow
Rate Units
SCFM, SCFH

32°F, 68°F, 77°F,
Custom Temperature

NLPM, NCMH

0°C

SLPM, SCMH

0°C, 20°C, 25°C,
Custom Temperature

Custom Ref. Temperature

Customer Ref. Pressure

Field Value

A value from -250 to 250
SCFM, SCFH

14.696 PSIA,
Custom Pressure

NLPM, NCMH

101.325 kPa

SLPM, SCMH

101.325 kPa,
Custom Pressure

Custom Pressure

A value from 10 to 1,000

Meter Filter Time Constant (sec)

A value from 0 to 600
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Measuring Mass Rate
The following tables describe the flow unit options:
• Pounds per Minute (PPM)
•

Pounds per Hour (PPH)

•

Kilograms per Minute (KPM)

•

Kilograms per Hour (KPH)

Table A-3 describes the mass rate options.
Table A-3.

Mass Rate Units
Field Name

Customer Ref. Temperature

Mass Rate Units
PPM, PPH

32°F, 68°F, 77°F,
Custom Temperature

KPM, KPH

0°C, 20°C, 25°C,
Custom Temperature

Custom Ref. Temperature

Customer Ref. Pressure

A–4

Field Value

A value from -250 to 250
PPM, PPH

14.696 PSIA,
Custom Pressure

KPM, KPH

101.325 kPa,
Custom Pressure

Custom Pressure

A value from 10 to 1,000

Meter Filter Time Constant (sec)

A value from 0 to 600
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Analog Outputs
Table A-4 and Table A-5 describe the Analog Outputs Commissioning field options. The second
analog output (AO2) fields are not available with the HART option.
Table A-4.

Analog Outputs Commissioning — AO1

AO1 Type

Field Name
AO1 4 mA Set Point

Velocity

SFPM, NMPS, or SMPS

AO1 20 mA Set Point
AO1 4 mA Set Point

Volumetric Rate

SCFM, SCFH, NLPM, NCMH, SLMP, or SCMH

AO1 20 mA Set Point
AO1 4 mA Set Point

Mass Rate
Table A-5.

Field Value Units

PPM, PPH, KGM, or KGH

AO1 20 mA Set Point
Analog Outputs Commissioning — AO2
Field Name

Field Value

AO2 4 mA Set Point

The default temperature is 32°F for English units.
The default temperature is 0°C for metric units.

AO2 20 mA Set Point

The default temperature is 77°F for English units.
The default temperature is 500°C for metric units.

Modbus Address
Table A-6 describes the Modbus Address field options.
Table A-6.

Modbus Address
Field Name

Field Value

Modbus Address

A value from 1 to 247

Baud Rate

9600, 14400, 19200, 38400, 57600
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Appendix B

USB Driver
Installation

Overview
This appendix provides information on installing the correct USB driver based on your Windows
computer and Kurz device configuration. The methods for accomplishing certain tasks and the
appearance of options depend on your operating system and permissions. Every effort has been
made to include potential dialog boxes and messages for all operating systems.
• Administrator privileges are required to install device drivers.
•

Windows XP, Vista, 7, and 8 are supported.

•

Confirming the USB connection requires that the B-Series flow meter is powered on and
connected to a Windows computer via a USB cable. USB ports are only active with a
connected, powered-on device.
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Using the Correct USB Driver
The Kurz USB device driver or FTDI USB device driver must be installed before attempting to
connect a computer with a B-Series device via a USB cable. Both drivers are available during the
KzComm installation, on the Kurz customer CD in the USB Device Driver folder, and on the Kurz
website (kurzinstruments.com). The FTDI USB driver is a 64-bit compatible virtual COM port (VCP)
driver available from the FTDI Chip website (ftdichip.com).
Each B-Series device has a barcode ID associated with the sensor control (SC) board that
determines the USB driver required for your computer.
• Barcode IDs that start with an A or B, or are less than C51937 use the Kurz USB driver. You
must explicitly install and assign the driver to the Kurz device.
•

Barcode IDs with C51938 or greater use the FTDI USB driver. The necessary driver should
install automatically when the device is connected via USB and the computer has internet
access.

The barcode ID is located in the following places:
• In a B-Series device menu.
1>

Enter Display mode by pressing D.

2>

Press 2 to invoke the Quick Jump option.

3>

Press 33 for the Calibration Coefficients menu, and then press E.
The barcode ID appears.

•

In the printable configuration file, as shown in the following example:
KURZ INSTRUMENTS, INC.
KZCOMM VERSION:
CONFIGURATION FILENAME:
FIRMWARE VERSION:
CONFIGURATION DATE:
ELECTRONIC BOARD BARCODE:
ELECTRONIC BOARD ASSY:
ELECTRONIC BOARD BUILD:

•

3.00
INSERTION_METER.cf
MFT-B VER H2.08
01/15/2013 13:54
C23096
420380
05 B

On the sensor control board.
Barcode ID
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Identifying the USB Driver
If the drop-down list for the COM Port field does not provide an identifiable name, open
Windows Device Manager. You can do this by using one of the following methods:
• For Windows XP, choosing Start→Run, typing devmgmt.msc in the Open field of the Run
dialog box, and pressing Enter.
•

For Windows Vista, 7, and 8, choosing Start and typing Device Manager in the search field.
You can select it when it appears as an option.

In the Device Manager window:
1> If present, expand Ports (COM & LPT), Other Devices, and Human Interface Devices.
If you installed the Kurz USB driver and a B-Series device with a barcode A, B or less
than C51938 is currently powered on and connected, it will be labeled as Kurz USB-HID
-> COM device.
If you installed the FTDI USB driver and a B-Series device with a barcode C51938 or
higher is currently powered on and connected, it will be labeled as USB Serial Port
(COM#).
If a USB-to-RS-485 adapter is used, its name may reference the manufacturer.
2>

To verify the port number, unplug the USB connector, and then plug it back in.
If the USB driver installed correctly, the COM port entry that disappears and reappears
in the Ports (COM & LPT) section represents the port used for the Kurz device.

The USB driver must be manually installed/re-installed when:
• The USB entry appears in the Other Devices or Human Interface Devices section.
•

The USB entry appears as USB Human Interface Device.

•

An old USB driver is used.

•

A yellow exclamation mark appears.
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Auto-Installing the FTDI USB Driver
The FTDI USB driver is available during the KzComm installation, on the Kurz customer CD in the
USB Device Driver folder, and on the Kurz website (kurzinstruments.com). The FTDI USB driver
is a 64-bit compatible virtual COM port (VCP) driver available from the FTDI Chip website
(ftdichip.com).
You must have administrator privileges to install the FTDI USB driver:
1. Locate the FTDI USB driver installer file.
If you are using the Kurz customer CD, locate the CDM20###_Setup.exe file on the CD.
If you are downloading the file from a website, locate where you downloaded the
installer file.
2.

Double-click the CDM20###_Setup.exe icon to start the FTDI USB driver installation.
If you have limited privileges, you can select the CDM20###_Setup.exe icon, right-click
and select Run as administrator.

3>

If prompted by the User Account Control to run the setup program, click Yes to allow the
program to make changes.

4>

If prompted to verify the installation, click Install to allow the program to make changes.
A command prompt window should appear showing that the driver is being installed.
Note

5>
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If the window does not appear, repeat the driver installation until you
see the command prompt window.

Open Windows Device Manager and follow the steps for ensuring the USB driver is
installed correctly, as described in “Identifying the USB Driver” on page B-3.
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Auto-Installing the Kurz USB Driver
The Kurz USB driver is available during the KzComm installation, on the Kurz customer CD in the
USB Device Driver folder, and on the Kurz website (kurzinstruments.com).
You must have administrator privileges to install the Kurz USB driver:
1. Locate the Kurz USB driver installer file.
If you are using the Kurz customer CD, locate the HidComInst.exe file on the CD.
If you are downloading the file from the Kurz website, locate where you downloaded
the installer file.
2.

Double-click the HidComInst.exe icon to start the Kurz USB driver installation.
If you have limited privileges, you can select the HidComInst.exe icon, right-click and
select Run as administrator.

6>

If prompted by the User Account Control to run the setup program, click Yes to allow the
program to make changes.

7>

If prompted to verify the installation, click Install to allow the program to make changes.

8>

The Kurz USB driver is not Windows logo tested. If prompted, click Continue Anyway.

9>

Open Windows Device Manager and follow the steps for ensuring the USB driver is
installed correctly, as described in “Identifying the USB Driver” on page B-3.
The Kurz USB driver should appear in the Ports (COM & LPT) section labeled as Kurz
USB-HID -> COM device (COM#). If the entry does not appear, turn off and then turn
on power to the B-Series device.
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Manually Installing the Kurz USB Driver for
Windows Vista, 7, and 8
You must have administrator privileges to install the Kurz USB driver:
1> The Kurz USB driver is available on the Kurz customer CD.
Insert the Kurz customer CD into a local CD drive or copy its content into a local folder.
2>

Open Windows Device Manager and follow the steps for ensuring the USB driver is
installed correctly, as described in “Identifying the USB Driver” on page B-3.

3>

Select the entry with the USB to Serial or USB Human Interface Device label and yellow
exclamation mark in the Other Devices or Human Interface Devices that is associated with
the B-Series device.

4>

Right-click on the label and select Update Driver Software.
The Update Driver Software dialog box appears.

5>

Click Browse my computer for driver software.
The Select Your Device’s Type dialog box appears.

6>

Select Show All Devices and click Next.
The Browse for Driver Software dialog box appears.

7>

Select Let me pick from a list of device drivers on my computer.
The Select the Device Driver dialog box appears. Even if the Kurz USB driver is listed,
you can re-install the latest driver if you are not sure of the version.

8>

Click Have Disk.
The Install From Disk dialog box appears.

9>

Click Browse.
The Locate File dialog box appears.

10>

Navigate to the Kurz customer CD, select the hidcom.inf file located in the Kurz USB Device
Driver folder, and click Open.
The Install From Disk dialog box appears.

11>

Click OK.
Kurz USB-HID -> COM device appears in the Model list.

12>

Select the driver and click Next.

13>

If a message appears indicating the driver is not digitally signed, click Continue.

14>

When prompted to install the device driver software, click Install.
The installation starts, followed by a message indicating a successful installation.

15>

If prompted, click Close to complete the installation.

16>

Open Windows Device Manager and follow the steps for ensuring the USB driver is
installed correctly, as described in “Identifying the USB Driver” on page B-3.
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Manually Installing the Kurz USB Driver for
Windows XP
You must have administrator privileges to install the Kurz USB driver:
1> The Kurz USB driver is available on the Kurz customer CD.
Insert the Kurz customer CD into a local CD drive or copy its content into a local folder.
2>

Open Windows Device Manager and follow the steps for ensuring the USB driver is
installed correctly, as described in “Identifying the USB Driver” on page B-3.

3>

Select the entry with the USB to Serial or USB Human Interface Device label and yellow
exclamation mark in the Other Devices or Human Interface Devices that is associated with
the B-Series device.

4>

Right-click on the label and select Update Driver.
The Hardware Update dialog box appears with a prompt in searching for the software.

5>

Choose No, not this time and click Next.
You are prompted for a search location.

6>

Choose Install from a list or specific location and click Next.
You are prompted for search and installation options.

7>

Choose Don’t search, I will choose the driver to install and click Next.
You are prompted to select the device driver. Even if the Kurz USB driver is listed, you
can re-install the latest driver if you are not sure of the version.

8>

Click Have Disk.
The Install From Disk dialog box appears.

9>

Click Browse.
The Locate File dialog box appears.

10>

Navigate to the Kurz customer CD or Kurz folder containing, select the hidcom.inf file
located in the Kurz USB Device Driver folder, and click Open.
The Install From Disk dialog box appears.

11>

Click OK.
Kurz USB-HID -> COM device appears in the Model list.

12>

Select the driver and click Next.

13>

If a message appears indicating the driver is not digitally signed, click Continue.

14>

When prompted to install the device driver software, click Install.
The installation starts, followed by a message indicating a successful installation.

15>

If prompted, click Finish to complete the installation.

16>

Open Windows Device Manager and follow the steps for ensuring the USB driver is
installed correctly, as described in “Identifying the USB Driver” on page B-3.
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